Exercicios de algoritmos

Destinado à análise e resolução de algoritmos utilizando-se como linguagem o português estruturado.

Exercicios de algoritmos

Mensagempor phfmiranda » Ter Mar 17, 2009 10:10 am

Em uma lanchonete o menu possui os seguintes itens:
Hambúrguer – R$ 1,80
XBurguer – R$ 2,00
XEggBurguer – R$ 2,30
Refrigerante – R$ 2,00

Faça um algoritmo que leia a quantidade pedida de cada item por um freguês e imprima a conta a ser paga por ele.

Resposta:

inicio
inteiro: quantham, quantxbur,quantxegg, quantrefr, total1, total2, total3, total4;
leia(quantham, quantxbur,quantxegg, quantrefr);
total1 <= quantham * 1,80;
total2 <= quantxbur * 2,00;
total3 <= quantxegg * 2,30;
total4 <= quantrefr * 2,00;
total <= total1 + total2 + total3 + total4;
imprima(“O total das compras é: “,total);
fim.

Elabore um algoritmo que leia uma quantidade de chuva em polegadas e imprima a quantidade equivalente em milímetros, sabendo-se que 1 polegada = 25,4 mm.

Inicio
real(quant);
inteiro(quantiequi);
leia(quant);
quantiequi <= quant * 25,4
imprima(“ A quantidade de chuva em milímetros será de: “,quantiequi);
fim.

Um empregado possui um salário fixo de R$ 460,00 e recebe mais R$ 10,00 por cada hora extra trabalhada. Faça um algoritmo que leia o nome e a quantidade de horas extras trabalhadas por este empregado em um determinado mês e imprima o nome seguido do salário a ser pago.

Resposta:

Inicio
real: extra, horas;
caracter: nome;
leia(nome);
leia(horas);
extra <= horas * 10
imprima(“O empregado, “ nome, “receberá o salário de R$”,extra);
fim.

Faça um algoritmo que calcule o número de latas de tinta necessárias para pintar uma parede retangular. As medidas da parede serão fornecidas em cm.
Obs: 1. O consumo de tinta é de 0,3 l/m2.
2. Deve-se calcular a menor quantidade de latas de tinta de tal forma que haja o
menor desperdício possível.
3. Existem no mercado latas de tinta com as seguintes capacidades: 3 litros, 2 litros e 1 litro.

Resposta:

inicio
a,b,área,consumo,total,div : real
leia(a,b);
consumo<= 0,3
area <= a*b
total <= area * consumo
div <= total/3
se mod >1 entao
div < mod / 2
se nao
se mod=1 entao
div <= mod/2
fim se
fim se
fim

Faça um algoritmo para calcular a raiz de uma equação do segundo grau. Imprimir a mensagem. Não existe raiz real, quando a equação não possuir raiz real.

Resposta:

inicio
real: a,b,c,raiz
real: equação
caracter: X
leia(a,b,c);
equacao<= a * x ^ 2 + b * x + c = 0
raiz<=b^2-4*a*c
se (raiz<0) então
escreva(“Não existr raiz real”);
senão
escreva(raiz);
fim se
fim

O Banco Lateral resolveu emitir uma mensagem de cobrança para os seus clientes em débito e dar uma bonificação de 0,02% sobre o saldo daqueles clientes que têm saldo superior a R$5.000,00.
Faça um algoritmo que leia o nome, o número da conta e o saldo de um cliente e imprima o nome, o valor da bonificação e o saldo total do cliente caso ele não esteja em débito, ou o nome e a mensagem “Acerte seu débito”caso o cliente esteja em débito.

Resposta:

inicio
caracter: nome;
real: saldo,conta,bonf;
leia(nome,conta,saldo);
se (saldo<0) entao
imprima(nome, "acerte seu debito");
se não
se (saldo>= 5000,00)então
bonf <= saldo* 1.02
imprima(nome,bonf);
se nao
imprima(nome,saldo);
fim se;
fim se;
fim

Elabore um algoritmo que leia três números inteiros e distintos, e imprima o seguinte:

a) o menor deles
b) a soma do maior com o menor
c) a diferença do número do meio com o menor

Resposta:

inicio
inteiro : x , y , z;
leia ( x y z );
se ( x > y ) e ( y >z ) então
escreva ( '' z'' '' x+z '' '' y -z'' );
se não
se ( x < y ) e ( x <z) entao
escreva ( x z +z y-x );
se não
se ( y >x ) e ( x>z) então
escreva ( z z+y x-z );
fim se;
fim se;
fim se;
fim.

Elabore um algoritmo que leia três valores inteiros e mostre-os em ordem crescente.

Resposta:

início
inteiro: nr1,nr2,nr3;
imprima("Entre com o primeiro número :");
ler(nr1);
imprima("Entre com o segundo número :");
ler(nr2);
imprima("Entre com o terceiro número :");
ler(nr3);
se(nr1 > n2)
se(nr1 > nr3)
se(nr2 > nr3)
imprima("Números em ordem crescente :",nr3,nr2,nr1);
senão
imprima("Números em ordem crescente :",nr2,nr3,n1);
fim se;
senão
imprima("Números em ordem crescente :",nr2,nr1,nr3;
fim se;
senão se(nr1 > nr3)
imprima("Números em ordem crescente :",nr3,nr1,n2);
senão se(nr2 > nr3)
imprima("Números em ordem crescente :",nr1,nr3,n2);
senão
imprima("Números em ordem crescente :",nr1,nr2,n3);
fim se;
fim

Implemente uma calculadora padrão.

inicio
real: n1,n2,result;
caracter: op;
leia(n1);
leia(op);
leia(n2);
se (op = “+”) então
result <= n1+n2
se não
se (op = “-“) então
result <= n1 – n2
se não
se (op = “*”) então
result <= n1 * n2
se não
se (op = “/”) então
result <= n1 / n2
se não
imprima (“operação invalida”);
fim se
fim se
fim se
fim se
imprima (result);
fim

Faça um algoritmo que leia três números positivos, e diga-se se estes valores podem formar um triângulo. Caso seja os lados de um triângulo imprimir o nome do tipo deste triângulo (isósceles, escaleno ou eqüilátero). Para tal, sabe-se que para formar um triângulo cada lado deve ser menor que a soma dos outros dois e maior que a diferença entre os outros dois, além de serem valores positivos.

Resposta:

início
inteiro: a,b,c
imprima (“entre com os três lados do triângulo”);
leia (a, b, c);
se ((a + b < c) ou (a + c < b) ou (b + c < a)) então
imprima (“ valores inválidos”);
senão
se ((a = b) e (b = c)) então
imprima (“eqüilátero”);
senão
se ((a = b) ou (a = c) ou (b = c)) então
imprima (“isósceles”);
senão
imprima (“escaleno”);
fim se
fim se
fim se
fim.

Tendo como dados de entrada a altura e o sexo de uma pessoa, construa um algoritmo que calcule seu peso ideal, utilizando as seguintes fórmulas:
Para homens: (72,7 * h) – 58
Para mulheres: (62,1 * h) – 44,7


Resposta:

Inicio
real: altura,
caracter: sexo;
leia(altura);
leia(sexo);
se sexo = masculino então
pesoideal <= (72,7 * altura) – 58
se não
pesoideal <= (62,1 * altura) – 44,7
imprima(“ O seu peso ideal é “, pesoideal);
fim.
Avatar do usuário
phfmiranda
Site Admin
 
Mensagens: 672
Registrado em: Dom Mar 08, 2009 1:19 am
Localização: Santos Dumont

Voltar para Lógica de Programação e Algoritmos

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 0 visitantes

cron